Не устанавливается ettercap, требует libltdl.so.3, но эта библиотека установлена

Автор: pirat Дата: 06.09.2009 19:30 собственно сабж, не ставится ни с помощью rpm, ни yum.
Re: не устанавливается ettercap, требует libltdl.so.3, но эта библиотека установлена 06.09.2009 21:01lg Покажите вывод комманд
rpm -q --provides libtool-ltdl
rpm -qRp ваш_файл_который_хотите_установить
ну и
rpm -ivh ваш_файл_который_хотите_установить
Re: не устанавливается ettercap, требует libltdl.so.3, но эта библиотека установлена 06.09.2009 21:23pirat rpm -q --provides libtool-ltdl
libltdl.so.7
libtool-libs = 2.2.6-11.0.140asp.1
libtool-ltdl = 2.2.6-11.0.140asp.1
rpm -qRp ettercap-0.7.3-30.fc10.i386.rpm
warning: ettercap-0.7.3-30.fc10.i386.rpm: Header V3 DSA signature: NOKEY, key ID 4ebfc273
/bin/sh
/bin/sh
/usr/sbin/alternatives
/usr/sbin/alternatives
ettercap-common = 0.7.3-30.fc10
libc.so.6
libc.so.6(GLIBC_2.0)
libc.so.6(GLIBC_2.1)
libc.so.6(GLIBC_2.1.3)
libc.so.6(GLIBC_2.3)
libc.so.6(GLIBC_2.3.4)
libc.so.6(GLIBC_2.4)
libcrypto.so.7
libdl.so.2
libform.so.5
libltdl.so.3
libmenu.so.5
libncurses.so.5
libpanel.so.5
libpcap.so.0.9
libpcre.so.0
libpthread.so.0
libpthread.so.0(GLIBC_2.0)
libpthread.so.0(GLIBC_2.1)
libresolv.so.2
libresolv.so.2(GLIBC_2.2)
libssl.so.7
libtinfo.so.5
libz.so.1
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(VersionedDependencies) <= 3.0.3-1
rtld(GNU_HASH)
rpm -ivh --test ettercap-0.7.3-30.fc10.i386.rpm
warning: ettercap-0.7.3-30.fc10.i386.rpm: Header V3 DSA signature: NOKEY, key ID 4ebfc273
error: Failed dependencies:
ettercap-common = 0.7.3-30.fc10 is needed by ettercap-0.7.3-30.fc10.i386
libltdl.so.3 is needed by ettercap-0.7.3-30.fc10.i386
Re: не устанавливается ettercap, требует libltdl.so.3, но эта библиотека установлена 06.09.2009 21:57lg У вас установлен новый libtool-ltdl, в котором есть libltdl.so.7 (а в идущем с дистрибутивом как раз идет so.3). Поскольку ettercap взят из федоры у вас есть несколько вариантов
1. Взять ettercap из fc11 (стоит попробовать, если не потянет кучу зависимостей). Оптимальный вариант, но скорее всего не получится
2. попробовать установить libttool-ltdl, который был в дистрибутиве, вполне возможно, что 2 пакета разных версий не будут конфликтовать
rpm -ivh --oldpackage [<a href="ftp://ftp.asplinux.ru/pub/i386/RPMS.14/libtool-ltdl-1.5.24-6.0.140asp.i386.rpm" rel="nofollow">ftp.asplinux.ru</a>]
3. вытащить libltdl.so.3 из старого пакета и установить ettercap и ettercap-common через rpm с --nodeps
4. пересобрать src.rpm ettercap из fc11 

Первый и последний варианты наиболее правильны, третий наиболее быстрый Улыбка

PS: осторожнее с первым вариантом
RSS-материал