Обновление *gimp*

Автор: radiosys Дата: 02.09.2003 23:54 Подскажите методику и средство поиска недостающих библиотек, например при попытке:
[root@DIR packages]# yum update *gimp*
Получение информации о пакетах
Получение заголовков с сервера: ASPLinux 9 Contribs
Получение заголовков с сервера: ASPLinux 9 Master Site
Получение заголовков с сервера: ASPLinux 9 Updates
Кеширование информации
Поиск обновленных пакетов
Получение необходимых заголовков
Разрешение зависимостей
[100%] ################################ пакеты

Пересчет учитывая новые зависимости, цикл 2
пакету xsane-gimp нужен libgimp-1.2.so.0 (не предоставлен или исключен)
пакету xsane-gimp нужен libgimpui-1.2.so.0 (не предоставлен или исключен)
пакету gimp-print-plugin нужен libgimp-1.2.so.0 (не предоставлен или исключен)
пакету gimp-perl нужен libgimp-1.2.so.0 (не предоставлен или исключен)
пакету xmorph нужен libgimp-1.2.so.0 (не предоставлен или исключен)
пакету gimp-print-plugin нужен libgimpui-1.2.so.0 (не предоставлен или исключен)
пакету gimp-perl нужен libgimpui-1.2.so.0 (не предоставлен или исключен)
пакету gimp-perl нужен gimp = 1.2.3 (не предоставлен или исключен)

имеем две недостающие библиотеки, как их разыскивать?
Re: Обновление *gimp* 03.09.2003 01:07Woodoo radiosys писал(а):

> Подскажите методику и средство поиска недостающих библиотек,

Общая методика пока такова (приблизительно):
---
yum list 'gimp*'
---
и видим версии пакетов, доступных к обновлению/установке.
Анализируя список, приходим к выводу, что пока обновился только gimp и gimp-devel (пишу по памяти). Версии пакетов-плагинов ниже и соответственно привязаны к предыдущим версиям gimp.
Отсюда выводы:
- если нам нужен новый gimp - удаляем старые плагины, обновляемся
- если нам нужны gimp&плагины - не обновляемся.

> пакету xsane-gimp нужен libgimp-1.2.so.0 (не предоставлен или
> исключен)
> пакету xsane-gimp нужен libgimpui-1.2.so.0 (не предоставлен
> или исключен)
> пакету gimp-print-plugin нужен libgimp-1.2.so.0 (не
> предоставлен или исключен)
> пакету gimp-perl нужен libgimp-1.2.so.0 (не предоставлен или
> исключен)
> пакету xmorph нужен libgimp-1.2.so.0 (не предоставлен или
> исключен)
> пакету gimp-print-plugin нужен libgimpui-1.2.so.0 (не
> предоставлен или исключен)
> пакету gimp-perl нужен libgimpui-1.2.so.0 (не предоставлен
> или исключен)
> пакету gimp-perl нужен gimp = 1.2.3 (не предоставлен или
> исключен)
>
> имеем две недостающие библиотеки, как их разыскивать?

Библиотеки, преставляемые в предыдущей версии. Вариант - удалить "пакеты-кокетки" - но по одному.
---
# yum remove gimp-perl
# yum remove gimp-print-plugin
...
---
Re: Обновление *gimp* 03.09.2003 01:53radiosys Понял, спасибо.
RSS-материал